Fi360 System Requirements

Fi360's web based application has certain internet browser requirements - if you use older versions of Internet Explorer, such as IE8 or older, you will not be able to see the typical log-in page for the Training and Designee Portal. Instead, you will get a message stating that you are using an unsupported browser.

In an effort to effectively provide new, cutting edge products and services to our customers, while also adhering to security and risk mitigation best practices, Fi360 has chosen to only support the use of the browsers listed below. We strongly recommend switching or upgrading your browser for the best experience on Fi360's platform.

Supported browsers: Mozilla Firefox, Google Chrome, Safari, Internet Explorer 10, Internet Explorer 11

Below are some alternatives for updating your browser or downloading another browser for use with Fi360's applications.

Update to Internet Explorer 11: http://windows.microsoft.com/en-us/internet-explorer/download-ie

Download a different browser:  https://browser-update.org/update.html

Have more questions? Submit a request